GPE - Após fechamento do período, Sistema não atualiza status para Fechado no cadastro de períodos

Ocorrência

No Módulo 7, Gestão de Pessoal, após fechamento do período, sistema não atualiza status para fechado no cadastro de períodos


Ambiente

TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12


Causa

Funcionários cadastrados em filiais inexistentes


Solução

O processo de fechamento de períodos da Folha de Pagamento envolve diversas tabelas do Sistema.

Neste caso o que pode ocasionar erro na atualização do status do período (campo FQ_STATUS) é existir funcionários cadastrados em filiais inexistentes.

Em casos de alteração de codificação de empresas/ filiais ou até mesmo inativação, é necessário que sejam feitos ajustes para estes funcionários, ou até mesmo transferi-los.

Este cenário é identificado através da análise dos dados gravados nas tabelas relacionadas (SRA - Cadastro de Funcionários e SYS_COMPANY - Cadastro de Empresas).


Atualizado em 14/04/2023
Este artigo foi útil?  
Agradecemos sua avaliação.