Ocorrência
Ao realizar a instalação de patch da Biblioteca ocorre erro:
"C:\totvs\CorporeRM\RM.Net\RM.Lib.dll
Ocorreu um erro ao tentar substituir o arquivo existente:
DeleteFile falhou; código 5.
Access is denied.
Clique em Repetir para tentar novamente, em Ignorar para ignorar este arquivo (não recomendado) ou em Cancelar para cancelar a instalação."
Ambiente
RM - Framework - Todas as versões do RM.
Causa
Esse incidente ocorre, pois a dll já existe e não está sendo possível substituí-la para atualização, por falta de permissão ou pois a mesma está em uso.
Solução
Ao realizar a instalação de patch, o instalador para o serviço do Host, atualiza os arquivos necessários e inicia o serviço novamente:
Para correção da ocorrência, siga os passos abaixo:
- Avalie se o usuário que está executando o instalador é administrador da máquina;
- Clique com o botão direito sobre o arquivo de instalação e em seguida clique em Executar como Administrador;
- Pare o serviço do Host através do aplicativo RM.Host.ServiceManager.exe (UNIDADE:\totvs\CorporeRM\RM.Net) e execute o instalador novamente com a opção (Executar como administrador);
- Reinicie a máquina e execute o instalador com a opção (Executar como administrador);
- Desinstale a Biblioteca .msi, reinstale a mesma e execute o patch com a opção (Executar como administrador).