Validação do HELP "MA280DTFEC" ao processar o Fechamento de Estoque

Ocorrência

Ao fazer a Virada de Saldos apresenta o HELP MA280DTFEC:

mceclip0.png

 

Ambiente

Protheus – Estoque/Custos – A partir da versão 12.1.17


Causa

Este erro ocorre porque o Protheus está tentado fazer a Virada de Saldos com a mesma data que já está gravada nas tabelas SB9, SBJ e SBK e/ou no parâmetro MV_ULMES. 


Solução

1. Verificar o parâmetro MV_ULMES para analisar é a data que está apresentando no último fechamento do estoque.

 

2. Verificar em suas tabelas SB9, SBJ e SBK se possui algum registro com data igual ou posterior.

Por exemplo, fazer uma consulta em seu banco de dados conforme o exemplo abaixo:

➣ Tabela SB9  - SELECT MAX(B9_DATA) FROM SB9T10 WHERE D_E_L_E_T_= '

Assim, irá retornar o valor maior do campo B9_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

 

➣ Tabela SBJ - SELECT MAX(BJ_DATA) FROM SBJT10 WHERE D_E_L_E_T_= '
Retornará o valor maior do campo BJ_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

 

➣ Tabela SBK SELECT MAX(BK_DATA) FROM SBKT10 WHERE D_E_L_E_T_= '
Pois irá retornar o valor maior do campo BK_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

 

3. Caso haja o diagnóstico de que realmente existem registros nas tabelas de Saldos Iniciais com data igual ou posterior à data ao qual está precisando fazer a Virada de Saldos, é recomendável uma analise interna para melhor entendimento (se já houve de fato uma virada de saldos), e se houve e foi de forma indevida, avaliar a possibilidade de reabertura do período de estoque.

 

Observação importante: o Protheus não dispõe de nenhuma rotina que reabra períodos de estoques, sendo um processo específico que a TOTVS recomenda fortemente que seja feito em acompanhamento junto à um analista in loco.

 


Atualizado em 23/11/2023
Este artigo foi útil?  
Agradecemos sua avaliação.