Ocorrência
No módulo de Estoque, ao tentar realizar o Recálculo do Custo Médio, apresenta a mensagem sobre "Erro na Chamada de Processo". O que fazer para resolver?
Ambiente
Protheus – Estoque/Custos – A partir da versão 12.1.17
Causa
Esta mensagem é exibida na tela quando utilizamos "Stored Procedures" e por algum motivo a Procedure gera uma inconsistência em sua execução.
Solução
Antes de seguirmos com as alternativas, é importante certificar-se de que a base esteja atualizada. Desta forma, para atualizar o pacote acumulado do Estoque/Custos, selecione a sua release e clique aqui
Obs: Sempre que aplicar um pacote ou fonte, efetue primeiramente em ambiente de homologação. Em caso de sucesso na aplicação, efetue no ambiente de produção.
Partindo da premissa que o acumulado do Estoque/Custos esteja atualizado, siga os passos abaixo:
1° - Através do modulo "Configurador (SIGACFG)" verifique se o conteúdo do parâmetro MV_CUSTEXC está configurado como "Compartilhado" conforme abaixo.
2° - Abra o arquivo "error.log" e verifique se houve algum incidente no processamento da rotina.
Importante: Antes de executar a rotina habilite a chave "TRACESTACK=1" no seu arquivo appserver.ini (Para informações maiores informações clique aqui).
3° - Abra o módulo "Configurador (SIGACFG)" e altere a quantidade de threads a serem executadas de forma simultânea através do parâmetro MV_A330THR (altere a quantidade para igual a 1).
Observação: Após a configuração do parâmetro execute a rotina de recalculo do custo médio e verifique se o incidente é reproduzido.
4° - Abra o dbAccess Monitor de seu ambiente e execute os procedimentos abaixo:
Abra o dbAccess Monitor, clique na aba "Mensagem" e aperte o botão "LIMPAR";
Execute a rotina "Recalculo do Custo Médio (MATA330)" e deixe a mensagem "Erro na Chamada do Processo" ser exibida na tela. Retorne ao dbAccess Monitor e verifique na aba mensagem a existência de algum texto de não-conformidade gerado pela rotina, caso exista solicite apoio a sua equipe de Tecnologia da Informação para avaliação.
5° - Via SIGACFG:
- Desinstale a Stored Procedure 19 via configurador.
- Faça um backup e delete a SP 19 da pasta \SYSTEM.
- Reinicie o TOPConnect.
- Cole a SP 19 na pasta \SYSTEM.
- Instale a SP 19 via configurador.
Caso nenhuma destas alternativas resolva, acione a equipe de Suporte Técnico evidenciando cada etapa deste documento e retorne na abertura do ticket os arquivos console.log, console.bak, error.log, appserver.ini, dbconsole.log, dbaccess.log, cópia da tabela SX6 e data dos fontes MATA330 e M330JCTB.